Help Center Live Community
April 21, 2014, 06:13:17 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1]   Go Down
  Print  
Author Topic: Accept Chat Operator Window Blank  (Read 6756 times)
ITEHQ
Not too much to say...
*
Offline Offline

Posts: 7


« on: November 29, 2007, 05:50:09 PM »

After someone comes into chat.  We get the accept or decline options. 

When clicking 'Accept' it will bring up the chat window on the user side but the operator gets a window that opens and is completely blank with a curser and hour glass but nothing happends and we have to restart IIS in order to reconnect to the website from that operators computer?

have granted EVERYONE FULL CONTROL to the entire directory.  Running on Windows Server 2003 PHP 5 and MySQL 5.

have also granted IUSR_SERVER (web user) FULL CONTROL to the entire directory. 

have the Java 6 update 3 installed on server and on the operators computers.

Allowed full write access to the web site through IIS.

None of the solutions on the forums have fixed my issue unless I have just missed something completely.  No matter what we change the issue remaines the same.

Please help as my company would love to PROMOTE this product but since it does not work we may have to go with another product.
Logged
ITEHQ
Not too much to say...
*
Offline Offline

Posts: 7


« Reply #1 on: November 29, 2007, 06:51:04 PM »

I have fixed the issue!!!!!!!!!  The issue has nothing to do with PHP, JAVA or Help Center Live it is a MySQL issue by default sets the my.ini file to strict mode and will give you a blank operator chat window when accept chat is clicked.  Hope this helps many other people as I spent several days working on this.

The issue was MySQL.

Open your "my.ini" file within the MySQL installation directory, and look for the text "sql-mode".
Find:

Code:
# Set the SQL mode to strict
sql-mode="STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"Replace with:

Code:
# Remove SQL mode strict
sql-mode="NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"
Logged
ITEHQ
Not too much to say...
*
Offline Offline

Posts: 7


« Reply #2 on: November 29, 2007, 07:40:22 PM »

Update to the FIX......

The issue of the operator chat window is still resolved but the chat messages are not being received on the operator and user end.

I will update with the solution once we narrow it down and do some testing to make sure that the chat messages are being received.

Logged
ITEHQ
Not too much to say...
*
Offline Offline

Posts: 7


« Reply #3 on: November 30, 2007, 01:37:41 AM »

Have tried many config options even letting mysql allow ALL access and it still will not receive chat requests.  Only seeing our own messages we type is pretty useless.

any help getting this going would be greatly appreciated.  If we can not get it resolved we will be switching to Crafty Syntax as we already have that up and running and has been stable since the day we installed. 

Maybe when version 3 is ready we can try testing this software again but right now it is just too unstable unless someone out there knows how to fix this issue.  More than likely there will be more issues with this product even after chat messages are received.

File transfer is not worth even trying at the moment since the main feature CHAT does not work.
Logged
HCL Admin
Administrator
HCL Superstar
*****
Offline Offline

Posts: 882


WWW
« Reply #4 on: December 03, 2007, 08:12:22 AM »

Are you using the mysql socket or a host address?
Logged

how may I help you today?
ITEHQ
Not too much to say...
*
Offline Offline

Posts: 7


« Reply #5 on: December 04, 2007, 06:51:03 AM »

I have fixed the issue on receiving chat requests to user and operator. 

You can not have Help Center Live running on its own website like chat.yourdomain.com, which is what I was doing then putting a link on my test.yourdomain.com website.  It thought it was talking with test.yourdomain.com and chat.yourdomain.com and it had no idea what to do. 

To fix the issue I created a folder in my web root directory for ( test.yourdomain.com/hcl ) and reinstalled Help Center Live. 

I was then able to start seeing each others chats. 

Of course as I have fixed one issue another one arises.  SMTP is now not working and it keeps putting a single encrypted digit into the password field for smtp and there is no password as I have it locked down by IP address so relay should be fine.  The program actually says it sends out the message and nothing gets stuck in my IIS que folder for emails.  If it is using PHP then it should be using default port 25.  I get no bounce back messages and no files, the mystery email that gets sent but no signs of it existing.

I am working on the issue and any help would be greatly appreciated
Logged
ITEHQ
Not too much to say...
*
Offline Offline

Posts: 7


« Reply #6 on: December 04, 2007, 07:02:31 AM »

Are you using the mysql socket or a host address?

I believe I am using the host address and not using sockets but I could be wrong, I did not change any of that to get chat working but might be what is causing the email issue.

I receive no errors on sending emails when offline but it says they are sent.
Logged
ITEHQ
Not too much to say...
*
Offline Offline

Posts: 7


« Reply #7 on: December 05, 2007, 02:07:47 AM »

Ok, I can not get E-mail to work I have tried to setup encryption and if I do then I get smtp errors on screen saying unable to authenticate but it still sends the email?HuhHuhHuhHuh  I thought unable to send email means unable to send email but I guess not.

I will be waiting for HCL version 3 to come out before using this product way to unstable for me to present to clients unfortunately, as I like the look of this product much more than crafty syntax but again crafty syntax has worked since the first day of installation with zero issues in chatting or emailing.

When this product has been revamped we will look at it again.
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.8 | SMF © 2006-2008, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 0.159 seconds with 19 queries.

Google visited last this page April 09, 2014, 07:21:03 PM