Help Center Live Community
April 16, 2014, 11:46:40 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1]   Go Down
  Print  
Author Topic: Does anyone have a working Initiate Chat?  (Read 15932 times)
HCL Admin
Administrator
HCL Superstar
*****
Offline Offline

Posts: 882


WWW
« on: June 18, 2007, 04:21:52 AM »

Looks like somewhere the initiate chat has gotten broken.  Does anyone have any version of HCL with a working initiate chat?  I'm trying to localize the bug, but it's been slow going, and if we can figure out where the bug got in, maybe I can track it down a little faster.

Thanks
    Michael
Logged

how may I help you today?
shawn
Not too much to say...
*
Offline Offline

Posts: 10


« Reply #1 on: June 18, 2007, 01:45:47 PM »

I have a version of initiate chat that works correctly...

Do you want me to zip it up and email it to you?

Let me know.

Thanks again,
Shawn
Logged
HCL Admin
Administrator
HCL Superstar
*****
Offline Offline

Posts: 882


WWW
« Reply #2 on: June 18, 2007, 03:22:10 PM »

Are you running the latest version of HCL?  If not the version number would be fine.  We've tested on 5 servers and 2.1.2 is NOT allowing initiate chat.  If you have 2.1.2 then yes a zip would be wonderful.  I would move it to your computer and remove the mysql password from the config file, but don't change anything else.
Logged

how may I help you today?
shawn
Not too much to say...
*
Offline Offline

Posts: 10


« Reply #3 on: June 19, 2007, 01:34:00 AM »

OK here you go... all zipped up.

http://www.godirectmusic.com/hcl-2.1.2.gif

rename .gif to .zip

The initiate function for sure works on this version.

Hope that helps you!
Shawn
Logged
shawn
Not too much to say...
*
Offline Offline

Posts: 10


« Reply #4 on: June 19, 2007, 01:35:30 AM »

eh... not working hehe... let me retry.
Logged
shawn
Not too much to say...
*
Offline Offline

Posts: 10


« Reply #5 on: June 19, 2007, 01:41:54 AM »

Here we go!!!!

http://www.godirectmusic.com/hcl-2-1-2.rar

Thanks again!!!
Shawn
Logged
HCL Admin
Administrator
HCL Superstar
*****
Offline Offline

Posts: 882


WWW
« Reply #6 on: June 19, 2007, 01:49:12 AM »

Thanks Shawn, I'll dig into it and try to figure out why so many others with 2.1.2 are having issues with it.
Logged

how may I help you today?
shawn
Not too much to say...
*
Offline Offline

Posts: 10


« Reply #7 on: June 19, 2007, 02:25:44 AM »

Hey no problem!

This is the a version I downloaded about 6 months ago or so. 

Hope that helps... please me know if you need anything else.

Thank you again,
Shawn
Logged
HCL Admin
Administrator
HCL Superstar
*****
Offline Offline

Posts: 882


WWW
« Reply #8 on: June 19, 2007, 03:26:06 AM »

One question, just to clarify, your able to initiate a chat with a client with a user that is browsing.  I just tried the source code on a problem system and not seeing any results.  Mind you, I haven't loaded the SQL up yet to see if there is an issue, and I'm using their config file.  However the differences between the config.php's is limited to the system specific items.

Logged

how may I help you today?
shawn
Not too much to say...
*
Offline Offline

Posts: 10


« Reply #9 on: June 19, 2007, 03:43:40 AM »

Yes, when the user is browsing pages, the system logs what page the user is on... at any point I can click initiate and the popup will open the initiate window asking for the users permission to start a new conversation.

You know what though... now I think about it, I was having problems with it too a while back when I installed it, I forgot what I did to make it work though.

The code that you have works correctly and if you want me to give you a login to the admin chat to test it, I will.  Just let me know.

Thanks,
Shawn
Logged
HCL Admin
Administrator
HCL Superstar
*****
Offline Offline

Posts: 882


WWW
« Reply #10 on: June 19, 2007, 03:57:40 AM »

No worries, sorry for what probably seemed an inane question, however I want this bug D.A.D. (Dead As a Doornail)... Cheesy  Seriously tho'  sometimes I say initiate and their thinking of client initiation, which isn't an issue.

I may take you up on the offer after I spend some time looking at the code.  I have this funny feeling it's something simple causing it.  Those seem like the real pains to locate.
Logged

how may I help you today?
shawn
Not too much to say...
*
Offline Offline

Posts: 10


« Reply #11 on: June 19, 2007, 12:57:22 PM »

Yeah... no problem.  Just let me know.

Thanks again,
Shawn
Logged
HCL Admin
Administrator
HCL Superstar
*****
Offline Offline

Posts: 882


WWW
« Reply #12 on: June 19, 2007, 05:35:53 PM »

Thanks to Shawn, we have a fix for the Initiate chat issue.  For some reason the image is timing out.  To allow the Initiate chat to operate change your config.php so the last line is the following:

Code:
// The number of milliseconds to show the initiate image
        $conf['initiate_timeout'] = '120000';
Logged

how may I help you today?
shawn
Not too much to say...
*
Offline Offline

Posts: 10


« Reply #13 on: June 20, 2007, 12:14:56 AM »

Yes!!!  That is what I changed... I knew if you mentioned it, I would remember.  It has been long time ago. hehe.

Excellent... thanks a bunch!
Shawn
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.8 | SMF © 2006-2008, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 0.167 seconds with 20 queries.

Google visited last this page April 14, 2014, 11:21:19 PM