Help Center Live Community

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Error During Setup  (Read 6954 times)

DeadBeet

  • Not too much to say...
  • *
  • Offline Offline
  • Posts: 17
Error During Setup
« on: July 05, 2007, 05:57:06 AM »

Invalid default value for 'useragent'

CREATE TABLE `hcl_traffic` (`id` int(255) NOT NULL auto_increment,`timestamp` int(255) default NULL,`ip` varchar(255) NOT NULL default '',`useragent` text NOT NULL default NULL,`hostname` varchar(255) NOT NULL default '',`referrer` text NOT NULL default NULL,`requests` int(255) NOT NULL default '0',`visits` int(255) NOT NULL default '1',`start` int(255) NOT NULL default '0',PRIMARY KEY (`id`)) TYPE=MyISAM;

I get this error when I am setting up the new version, did I miss something?
Logged

DeadBeet

  • Not too much to say...
  • *
  • Offline Offline
  • Posts: 17
Re: Error During Setup
« Reply #1 on: July 05, 2007, 06:11:26 AM »

I figured it out with the Update file in the same directory.

If you run into the same problem replace the two lines with these:

  `useragent` text default NULL,

  `referrer` text default NULL,

Yes, I know theres a line in the middle between those two, but it doesn't need to be modified
Logged

HCL Admin

  • Administrator
  • HCL Superstar
  • *****
  • Offline Offline
  • Posts: 882
    • Help Center Live
Re: Error During Setup
« Reply #2 on: July 05, 2007, 06:16:42 AM »

Exactly, I'm releasing a database.sql update today and 2.1.3a will be uploaded to SF.  This was a packaging error on my part.
Logged
how may I help you today?

DeadBeet

  • Not too much to say...
  • *
  • Offline Offline
  • Posts: 17
Re: Error During Setup
« Reply #3 on: July 05, 2007, 06:18:22 AM »

You're not expected to be perfect:)
Logged

HCL Admin

  • Administrator
  • HCL Superstar
  • *****
  • Offline Offline
  • Posts: 882
    • Help Center Live
Re: Error During Setup
« Reply #4 on: July 05, 2007, 06:44:11 AM »

Yes but it's fun trying! :D
Logged
how may I help you today?

HCL Admin

  • Administrator
  • HCL Superstar
  • *****
  • Offline Offline
  • Posts: 882
    • Help Center Live
Re: Error During Setup
« Reply #5 on: July 05, 2007, 07:11:01 AM »

Hotfix has been uploaded to: http://www.helpcenterlive.com/dru/fileshare/files/17/hcl-hotfix-2.1.3-19.zip  This will repair any 2.1.3 install that is failing due to errors in the creation of MySQL tables.  Sorry about that folks!
Logged
how may I help you today?

DeadBeet

  • Not too much to say...
  • *
  • Offline Offline
  • Posts: 17
Re: Error During Setup
« Reply #6 on: July 05, 2007, 07:18:25 AM »

Thank you for the help!
Logged
Pages: [1]   Go Up
 

Page created in 0.181 seconds with 17 queries.