Help Center Live Community
April 20, 2014, 04:53:42 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1] 2   Go Down
  Print  
Author Topic: FIXED: Please wait while we connect you Error  (Read 11544 times)
daemonkin
Not too much to say...
*
Offline Offline

Posts: 12


Yippe Ky Yay MoFo


WWW
« on: April 30, 2009, 09:15:56 AM »

Hi guys,

Followed all setup instructions and have managed to patch any problems encountered so far including changing some include requests to other directories to fit my personal build. 

I have added the button code to a test site for online/offline help and have got up the nickname screen but when I request a chat I get the: Please wait while we connect you screen. 

When I login to Admin section and go to Live Chat and request chat I get: Please wait while we connect you. 

So now I have 2 screens 1 for client, 1 for admin both waiting to be connected. 

Please tell me there is something silly that I have not done. 

PHP 5+, MySQL 5.  0.  2

Regards,
D. 
« Last Edit: May 11, 2009, 12:42:20 PM by daemonkin » Logged

If Avian Flu and Swine Flu combine we will have Flying Pig Flu - Doom and Gloom!
acer_sage
Not too much to say...
*
Offline Offline

Posts: 2


« Reply #1 on: May 03, 2009, 07:10:32 AM »

Having the same problem. .  How can we fix it?
Logged
shishiogen
Not too much to say...
*
Offline Offline

Posts: 1



WWW
« Reply #2 on: May 03, 2009, 04:03:30 PM »

Yes, i'm having the same error.  .  .   "Please wait while we connect you" .  .   show in 2 popups .  .   client and admin.  .  
help us.   how to fix it?
« Last Edit: May 03, 2009, 04:08:24 PM by shishiogen » Logged

Binh Duong Online Services hxxp: bos. vn
ChayZO Group hxxp: chayzo. com
bindassweb
Not too much to say...
*
Offline Offline

Posts: 3


« Reply #3 on: May 03, 2009, 04:09:28 PM »

try to open clint and admin with two diffrent ip's
Logged
daemonkin
Not too much to say...
*
Offline Offline

Posts: 12


Yippe Ky Yay MoFo


WWW
« Reply #4 on: May 08, 2009, 02:26:20 PM »

Tried that and still no joy.  Any other suggestions appreciated.

Regards,
D.
Logged

If Avian Flu and Swine Flu combine we will have Flying Pig Flu - Doom and Gloom!
Destro
Not too much to say...
*
Offline Offline

Posts: 26


« Reply #5 on: May 08, 2009, 04:07:02 PM »

Hello,

Which browser(s) are you running, as that makes a lot of difference?

Destro
Logged

Destro
------------------------------------------
I'll try to help as much people as possible, so don't hestitate to ask.
But I am NOT officially a member of this project!
SpenserJ
Moderator
HCL Regular
*****
Offline Offline

Posts: 179

Some helpful guy


WWW
« Reply #6 on: May 09, 2009, 12:01:31 AM »

Yes, browser AND operating system make a difference. . .  for instance, I am running Firefox and Safari on OS X, and it does not work at all (or at least I haven't fixed it yet), however I can run it perfectly fine in IE on Windows, and with two small changes it works in Firefox on Windows too.

So please tell us your browser(s) and Operating System.  And perhaps read through some of the stickies on the forum, as they are quite useful!

Spenser
Logged

I am NOT a developer for HelpCenterLive. I am just trying to help out anyone that has issues. If you have a problem, check the list of fixes and then create a new topic
NJAquaman
Not too much to say...
*
Offline Offline

Posts: 2


« Reply #7 on: May 09, 2009, 03:19:16 PM »

Quote from: SpenserJ link=topic=963. msg3945#msg3945 date=1241823691
. . . and with two small changes it works in Firefox on Windows too. 

What Changes did you make to work with Firefox ? addons?  Huh
i am haveing the same problem !

thanks
SpenserJ  Grin
Logged
SpenserJ
Moderator
HCL Regular
*****
Offline Offline

Posts: 179

Some helpful guy


WWW
« Reply #8 on: May 09, 2009, 10:36:49 PM »

Nope, if you read a few of the topics on here you will find that a lot of the problems are already fixed.  But it is a little overwhelming as there are many different things it could be. . .

hxxp: www. helpcenterlive. com/smf/firefox_306_killed_this-t855. 0. html;msg3911#msg3911

That is the post I followed to fix the firefox in windows issues
Logged

I am NOT a developer for HelpCenterLive. I am just trying to help out anyone that has issues. If you have a problem, check the list of fixes and then create a new topic
Zulaika
Not too much to say...
*
Offline Offline

Posts: 3


« Reply #9 on: May 10, 2009, 06:34:05 PM »

I have replaced
Code:

Code:
this. fallback = false;
to
Code:
Code:
if (navigator. appName == 'Microsoft Internet Explorer') {
    this. fallback = false;
} else {
        this. fallback = true;
}

in thee class/js/aardvark.    php to fix firefox issue and keep default setting for IE.     Also, now helpcenterlive works fine in Opera browser too.   

-noise (All credit goes to Noise)
Logged
SpenserJ
Moderator
HCL Regular
*****
Offline Offline

Posts: 179

Some helpful guy


WWW
« Reply #10 on: May 10, 2009, 09:49:50 PM »

Keep in mind that the fix doesn't change anything for people using Mac OS X, only windows and linux users
Logged

I am NOT a developer for HelpCenterLive. I am just trying to help out anyone that has issues. If you have a problem, check the list of fixes and then create a new topic
daemonkin
Not too much to say...
*
Offline Offline

Posts: 12


Yippe Ky Yay MoFo


WWW
« Reply #11 on: May 11, 2009, 08:34:05 AM »

Thanks for replies.
Using Firefox 3. 0. 10
Windows XP SP3

Tried replacing the aardvark. php script to:
Code:
if (navigator. appName == 'Microsoft Internet Explorer') {
    this. fallback = false;
} else {
        this. fallback = true;
}

but to no help.

If it matters, I have placed the Online/Offline button script on 1 dev site and have the HCL dir on another dev site.

I login as an operator on site A.  Refresh site B to get the 'Online' button and start conversation.  I get:
'Please wait while we connect you'

I then select the operator I have logged in as and 'Request Chat' and get the same 'Please wiat while we connect you'

It's as if something is not being passed between the 2 communication screens and to the database.

Does any of this help? Should I try Safari on XP?

regards,
D.
Logged

If Avian Flu and Swine Flu combine we will have Flying Pig Flu - Doom and Gloom!
daemonkin
Not too much to say...
*
Offline Offline

Posts: 12


Yippe Ky Yay MoFo


WWW
« Reply #12 on: May 11, 2009, 08:38:47 AM »

OMG!

First time I ran it in Safari and the thing works perfectly.  This is an excellent piece of kit.

Just need to figure out why it is not working in FF or IE.

Time for some reading!

Regards,
D.
Logged

If Avian Flu and Swine Flu combine we will have Flying Pig Flu - Doom and Gloom!
daemonkin
Not too much to say...
*
Offline Offline

Posts: 12


Yippe Ky Yay MoFo


WWW
« Reply #13 on: May 11, 2009, 11:22:23 AM »

Sorted. 

I was replacing the wrong section /class/js/aardvark.  php.   It may need to be clearer but I was replacing:
function Aardvark(object) {
 this. object = object;
 this. xmlhttp = new XMLHttpRequest();
 this. mac = navigator. platform. indexOf('Mac');
 this. msie = navigator. userAgent. indexOf("MSIE");
 this. image = new Image();
 if (navigator.  appName == 'Microsoft Internet Explorer') {this.  fallback = false;} else {this.  fallback = true;};
 this. url = '';
 this. variables = new Array();
 this. vars = new Array();
 this. connect_host = '';
 this. install_host = '';
 this. initiated = false;
 this. url_built = false;
 this. response = '';
 this. gc = 'reset';
 this. validateurl = function(){
     this. connect_host = this. url;
    this. install_host = document. location. toString();
    this. connect_host = this. connect_host. replace(/(. *?)\/\/(. *?)\/(. *)/i, "$1//$2");
    this. install_host = this. install_host. replace(/(. *?)\/\/(. *?)\/(. *)/i, "$1//$2");
    this. connect_host = this. connect_host. replace(/(. *?)\/\/(. *?)/i, "$2");
    this. install_host = this. install_host. replace(/(. *?)\/\/(. *?)/i, "$2");
    if (this. connect_host !== this. install_host) {
             this.  fallback = false;
   }
}

Correct code in green.   Wrong code in red.   Now for some testing. 

D. 
Logged

If Avian Flu and Swine Flu combine we will have Flying Pig Flu - Doom and Gloom!
SpenserJ
Moderator
HCL Regular
*****
Offline Offline

Posts: 179

Some helpful guy


WWW
« Reply #14 on: May 11, 2009, 06:30:15 PM »

You shouldn't need to change that second portion.  You are going to need to change two files and replace the first reference to this. fallback with the same code.  One in class/js/aardvark. php, and one in class/js/normal/aardvark. php

One of those files is the normal code (easy to read) and one is compressed (on very few lines) so you will have to search for the code to replace.

In class/js/aardvark. php, look on the first line of code (after the comments) for this
Code:
function Aardvark(object) { this.object = object; this.xmlhttp = new XMLHttpRequest(); this.mac = navigator.platform.indexOf('Mac'); this.msie = navigator.userAgent.indexOf("MSIE"); this.image = new Image();

Right after that you will see something about this. fallback, you will want to replace that code (something like this. fallback = false;) with:
Code:
if (navigator.appName == 'Microsoft Internet Explorer') {this.fallback = false;} else {this.fallback = true;} this.url = '';

The next file you need to modify is class/js/normal/aardvark. php.   On line 50 you will find something like "this. fallback = false;" and you must change that to the above code as well.

Once you do that, HCL should work in all browsers on Windows and Linux (but still not OS X).  Just remember, you ONLY need to change the first reference to this. fallback in class/js/aardvark. php, and class/js/normal/aardvark. php
Logged

I am NOT a developer for HelpCenterLive. I am just trying to help out anyone that has issues. If you have a problem, check the list of fixes and then create a new topic
Pages: [1] 2   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.8 | SMF © 2006-2008, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 0.175 seconds with 20 queries.

Google visited last this page April 16, 2014, 10:56:25 PM