Help Center Live Community
July 24, 2014, 11:41:37 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1]   Go Down
  Print  
Author Topic: Operators get logged off after 4 or 5 minutes  (Read 3870 times)
lane
Not too much to say...
*
Offline Offline

Posts: 4


« on: August 26, 2009, 11:05:37 PM »

HCL seems to be working fine except that the operators get bumped off after 4 or 5 minutes.

I have been using HCL for seven or eight months with no problems, then lately the live help operator screen (browser) would lock up (quit monitoring) and then if you wait long enough the operator gets logged out.  you can restart (close browser monitor window and restart)the live help from the control panel if you catch it quick enough.

I reinstalled the latest version of HCL.  I have installed the Firefox patch to the Two Aardvark files.  I was using firefox as the browser to monitor.  Tried explorer8 to see if it would make any differance, it didn't. 

Anyone else having the same problem?

Do the browsers (firefox and explorer) timeout on running the scripts? If they do - does any one know how to change them.


Thanks
Lane
Logged
MF1590
Not too much to say...
*
Offline Offline

Posts: 14


« Reply #1 on: September 09, 2009, 02:44:02 PM »

Having the same problem - operators get kicked out randomly and dont even realize (until you hit refresh in the operator window).

Have set the timeout time to 8h which had fixed the problem for a while (few months) but it now happens again pretty often.

Will double check my options file and see what I can tweak there.
Any comments or help would be greatly appreciated!

Thank you
Logged
MF1590
Not too much to say...
*
Offline Offline

Posts: 14


« Reply #2 on: September 09, 2009, 03:12:39 PM »

To give you more details:

Have tried multiple browsers configurations on both sides (client/operator, Safari/Opera/Firefox/IE)
Windows XP, Server: Linux, Apache, PHP 5.    2.    8, My SQL 5.    0.    45 (according to phpinfo.    php)
Have created the image code with CoBrowse and CoForm.

Have added the aardvark fix for IE and Firefox.

The timeout option in the config. php file has been changed to: (line 177)

// The number of seconds the operator can remain idle until
// their status changes to offline
//$conf['live_timeout'] = '40';
$conf['live_timeout'] = '32400'; //9 hours

This workes/worked - I have to boot a lot of operators at night to make sure the chat goes offline (hard to get theem to hit logout, they just shut down the computer)

But I have seen multiple times that I get kicked out even though I was just active in the chat.

Any ideas on how to fix this? Happens randomly to my operators (15)

THanks for your ideas or comments
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.8 | SMF © 2006-2008, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 0.158 seconds with 19 queries.

Google visited last this page July 18, 2014, 02:06:20 PM