Help Center Live Community

Development => Core System Development => Topic started by: mmft1359 on August 19, 2009, 04:59:36 AM



Title: UTF-8 Character Coding
Post by: mmft1359 on August 19, 2009, 04:59:36 AM
Hi
I translated HCL to FARSI (Persian) and changed character coding from "ISO-8859-1" to "UTF-8" in all files.
two problems were found:
1- in main page online/offline icon not displayed.
2- when i want to become online (as admin user or any operators) the opened page doesn't have any content.   

can anybody help me.
thanks a lot . 


Title: Re: UTF-8 Character Coding
Post by: SpenserJ on August 19, 2009, 06:25:55 AM
The first issue is probably fairly simple, as this issue has occurred multiple times and you should be able to find the solution on the forum. As for the second issue, I do not know what the issue would be. Does the english translation work properly?

Spenser


Title: Re: UTF-8 Character Coding
Post by: mmft1359 on August 19, 2009, 06:48:21 AM
hi
yes english translation work properly.  
when FARSI translation file (FARSI.   php) saved as ANSI it works good but characters confused.  
But when FARSI.   php saved as UTF8 above 2 problems were found but characters seems good.   

please see my site:
taftiau. ac. ir/hcl

thanks


Title: Re: UTF-8 Character Coding
Post by: SpenserJ on August 19, 2009, 07:53:14 PM
Looks fine to me, but I cannot see the admin pages either.

As for the issue with the image not showing, make sure to add some departments and such. It may be failing to display the image because it is currently trying to get department ""