Help Center Live Community

Support => Installation Help & Software Support => Topic started by: chrisegilo on July 22, 2007, 03:39:24 PM



Title: Live Chat Looping
Post by: chrisegilo on July 22, 2007, 03:39:24 PM
When I try to monitor my site, it attempts to call /admin/monitor/index.php howver the link will forward me back to /admin/index.php and I am unable to monitor.

I am on a Windows Server.  I have tried it in 3 browsers: Mozilla, Opera, IE7, I have cranked up the permissions, and I have set up an operator department and assignment. I downloaded the newest Java plug in at Java.com for all the browsers.

Any ideas?

Regards,

Chris.


Title: Re: Live Chat Looping
Post by: chrisegilo on July 23, 2007, 01:23:59 AM
I have a problem where I cant get into LIVE CHAT.  I have done all the basic stuff Operator, Assignment, Departments, Code in pages, This saga started with the "Header" problem that everyone is having and the extra bit in Config just FYI.  Here is my problem and what I have done to troubleshoot it...

I am using the current version of HCL, and I am on a Winodws Server.

1, When I click on live help, the box pops up however it goes into the admin menu in the small box.  I am unable to monitor the website or see the life chat screen:

1. downloaded newest Java plug ins, Tested and updated Java on IE7, OPERA, And FIrefox, None of them worked.
2. I reinstalled in new subdomains, I used three different versions, getting the same error.
3. I used each template and tryed new online graphics.
4, I cranked the permissions to full at one point still no screen.

Somone Please help this is killing me!

Thanks,

Chris.


Title: Re: Live Chat Looping
Post by: HCL Admin on July 23, 2007, 12:56:00 PM
What server software are you using, and if apache, which version?  Also which version of PHP?


Title: Re: Live Chat Looping
Post by: chrisegilo on July 25, 2007, 03:45:37 AM
I am using Hello, PHP 4.4 and SQL Server 2000 and Windows IIS, And I have tested several versions of HCL on Opera, IE7 and Firefox.  The site is located at help.net1x.com/911/.

Thanks for your help,

Regards,

Chris Egilo


Title: Re: Live Chat Looping
Post by: HCL Admin on July 25, 2007, 04:22:54 AM
Ah, do you have MySQL on there as well?  SQL server is not compatible at this time.


Title: Re: Live Chat Looping
Post by: chrisegilo on July 25, 2007, 02:08:11 PM
Its on MySQL Server and I use PHPMyAdmin to adminisister it.  I also have MSSQL PhpPgAdmin, PgSQL Server.  My server provider said that the SQL and MySQL are the same thing to him??!!

Thanks for your help,

Chris Egilo.


Title: Re: Live Chat Looping
Post by: HCL Admin on July 25, 2007, 02:16:04 PM
SQL is a language, like English, however MSSQL, Postgres, MySQL, etc. are all dialects of that language.  Just like English, where you have all the varied dialects.  Computer are not like humans however, while we can adjust for different turns of phrase and understand each other, computers require precision.  Thus only your MySQL server will work with HCL at this time (3.0.0 will incorporate a new "plug-in" architecture which will allow different DB engines to be used.  For the 2.x.x series however, it's MySQL or the highway. :(

I'll build a debug file for your system and send it to you today.  This should give some insight to what's happening.


Title: Re: Live Chat Looping
Post by: HCL Admin on July 25, 2007, 02:26:25 PM
File is on it's way to your e-mail address.


Title: Re: Live Chat Looping
Post by: chrisegilo on July 25, 2007, 05:03:41 PM
http://help.net1x.com/911/*

Its ready to go!

Thanks, I am anxious to see whats up!

Chris.


Title: Re: Live Chat Looping
Post by: HCL Admin on July 25, 2007, 05:22:41 PM
Great, permissions are great, so I'll look at the PHP variables and see if there is anything there.


Title: Re: Live Chat Looping
Post by: chrisegilo on July 25, 2007, 06:30:38 PM
Awsome, let me know, I'm on pins and needles here!

Regards,

Chris Egilo.


Title: Re: Live Chat Looping
Post by: HCL Admin on July 25, 2007, 07:04:21 PM
Just curious, could you PM me the $conf['url']=??? part of your config.php?  You have some very strange rewrites going on there.


Title: Re: Live Chat Looping
Post by: chrisegilo on July 25, 2007, 10:25:11 PM
I sent the file information, hopefully you recived it...

Regards,

Chris Egilo.


Title: Re: Live Chat Looping
Post by: chrisegilo on July 28, 2007, 04:17:16 AM
Any news on this one.  I still can't get the live chat to work?

Thanks,

Chris Egilo.


Title: Re: Live Chat Looping
Post by: HCL Admin on July 28, 2007, 06:52:51 AM
As I mentioned in PM, I'm still trying to replicate the problem.  So far, the PHP.ini file is working, so I don't think it's necessarily the server settings.  A very perplexing issue for certain.


Title: Re: Live Chat Looping
Post by: chrisegilo on July 28, 2007, 10:33:44 PM
Could the problem be that the session.save_path in the php.ini file needs to point to a static directory?  I think that is the problem, however I don't have access to my PHP.ini file.  Food for thought.

Regards,

Chris Egilo.


Title: Re: Live Chat Looping
Post by: HCL Admin on July 28, 2007, 11:03:50 PM
Is your hcl install directory world writeable?  If not, yeah, that can cause an issue.  Really this is a poor way to setup the server. 

Check with your hosting provider about why this is set this way.  Having it set this way, you have to give directory write access, a patently bad idea.