Help Center Live Community

Support => Installation Help & Software Support => Topic started by: gazoi on August 25, 2007, 09:00:03 AM



Title: Delete Transcripts Error
Post by: gazoi on August 25, 2007, 09:00:03 AM

This is to fix the error below when trying to delete transcripts:

Fatal error: Call to undefined function: admin() in hcl/admin/transcripts.php on line 59

Fix is easy enough though. Replace the admin() function call on line 59 with the below:

Code:
59c59
<       if ($GLOBALS['conf']['opdelete'] === true || $GLOBALS['auth']->admin()){

---
>       if ($GLOBALS['conf']['opdelete'] === true || admin()){






Title: Re: Delete Transcripts Error
Post by: HCL Admin on August 26, 2007, 12:06:58 AM
We need to shoot the idiot that did that one, er, wait a minute.... :)  Thanks for finding and fixing that Gazoi! :)

I'll add it to the SVN today.  8)


Title: Re: Delete Transcripts Error
Post by: gazoi on September 18, 2007, 10:48:22 AM

I recently installed vers 2.1.5 and noticed when I diffed against 2.1.4 that this fix hadn't been merged into the current source, even though you mentioned in the changelog it had been fixed?

"- Fixed problem with transcript deletion"

On line 59, if...

Code:
if ($GLOBALS['conf']['opdelete'] === true || admin()){

is replaced by

Code:
if ($GLOBALS['conf']['opdelete'] === true || $GLOBALS['auth']->admin()){

that should fix the error.



Title: Re: Delete Transcripts Error
Post by: HCL Admin on September 18, 2007, 11:54:09 AM
Hmm, I remember making the change, but I'm not seeing it in SVN.  I just re-did the change and the commit, and double checked the SVN to ensure it's in there. 

edit: found the issue, I had one computer set to a different SVN repo, so a couple of updates happened to that old (obsolete) repo, and the rest had been done to the current repo.  I've not only shifted the errant computer to the correct repo but also killed write access to the old one so I spot the issue before shooting myself in the foot!