Help Center Live Community

Support => Installation Help & Software Support => Topic started by: rickou812 on February 18, 2008, 11:08:39 AM



Title: New install need assistance
Post by: rickou812 on February 18, 2008, 11:08:39 AM
I have a fresh install of HCL.  Latest version 2.1.5.  Everything went well, conf. file is set correctly, I think.  database installed without issue.  I can monitor site, but can not initiate or receive chats.  Whenever attempted, it just refreshes back to "Must choose a nick name" and I see http://www.mysite.com/hcl/live/main.php?retry at the top of the window.  And if I try to initiate chat , I get the new window with the initiate button, but when clicked, nothing happens.  Also note that if a support ticket is entered, it goes to the "email sent" page, but I never receive an email. 
I have noted that some information is being captured in the database, such as number of traffic, and info, but nothing related to communication...
I tried with firefox and ie7...

Any help would be greatly appreciated.

Thanks,
Richard


Title: Re: New install need assistance
Post by: rickou812 on February 18, 2008, 07:13:59 PM
bump back to the top, I do not want this to get buried, I really need help.

I have looked through the FAQ and the Docs, installation page, and searched with out finding anything to solve my problem...

Thanks,
Richard


Title: Re: New install need assistance
Post by: victor on February 18, 2008, 09:17:01 PM
send me your URL via PM so I can check it from here


Title: Re: New install need assistance
Post by: oraclesoon on February 20, 2008, 10:02:22 AM
Please refer here for the 2 test cases:
http://www.helpcenterlive.com/smf/index.php/topic,386.msg2203.html#msg2203

When the visitor window says "Must choose a nick name", that means you need to enter a Nickname.

In order to receive email, when you create the Department, you may put the SMTP host as "localhost" (if you are using Linux). If you are using Windows, then you need to put a valid smtp server.


Title: Re: New install need assistance
Post by: kees@qrios on October 28, 2008, 09:27:12 AM
This might be related. 

I'm on v 2.  1.  7. 
My problem is, when a visitor tries to initiate a chat without a nickname, he is redirected to live/main.  php?retry.   It's obvious, the "departmentid" parameter is lost.   So, the visitor gets a warning "choose departement".   Frustrating. 

Solutions is simple:
/live/request.  php line 75 was:
                header('Location: '.  $GLOBALS['conf']['url'].  '/live/main.  php?retry');

This must be:
                header('Location: '.  $GLOBALS['conf']['url'].  '/live/main.  php?retry&departmentid='.  $departmentid);

Greets,

Kees



Title: Re: New install need assistance
Post by: spayne on January 19, 2010, 10:00:07 PM
EDIT: Clean install and the firefox aardvark fix solved my issues.