Help Center Live Community

Support => Tips and Tricks => Topic started by: pcolella on March 26, 2009, 02:09:48 PM



Title: Sound issues with Firefox 3.0.7
Post by: pcolella on March 26, 2009, 02:09:48 PM
For those of you using the new Firefox 3. 0. 7 and having sound issues here's a fix.  The embed tag needs a MIME qualifier such as type="audio/mpeg" so you will need to modify the template file monitor_content. tpl and add this to the embed tag.

Also broken is the beep while chatting.  For that you'll have to edit the chat. php file found in class/js and add an embed tag within the object tag.

Hope this helps anyone that was having the same issues.


Title: Re: Sound issues with Firefox 3.0.7
Post by: unix4linux on June 12, 2009, 12:55:56 PM
Pcolella,

Would you be kind and point out exactly where these files are and where in the file these changes have to be made.   I am not a coder and a little guidance on where to make these changes would be of great help.

I am also experiencing this problem with sound.


Title: Re: Sound issues with Firefox 3.0.7
Post by: SpenserJ on June 12, 2009, 04:46:59 PM
Sadly I don't have a local HCL install anymore, so I can't tell you exactly, but if you look for any folders relating to themes or templates you will find it quick enough. In that main themes/templates folder, there is one called G and one called Bliss (I think). Inside there just modify monitor_content.tpl. Do a search for <embed and you will find the line to change. Just add it inside the tag (<embed> becomes <embed type="audio/mpeg">, but of course it isn't an empty tag, or I don't think it is)

As for the beeping, from the main HCL directory, open up class/js/chat.php and also search for <embed and add it the same (or maybe this one is <object, sorry, I can't remember as I patched it a while ago). However if you look in those files you should find it. In the template file it is closer to the bottom, can't remember where in chat.php

Spenser