Help Center Live Community
July 22, 2014, 08:43:26 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1]   Go Down
  Print  
Author Topic: A quick bug fix / suggestion  (Read 4322 times)
batobin
Not too much to say...
*
Offline Offline

Posts: 1


« on: September 13, 2007, 01:27:42 AM »

More of a suggestion than a bug fix. I noticed that by default you comment out the following line in config.php:

$conf['demomode']=true;

I would suggest that you don't comment the line, but rather leave it intact like this:

$conf['demomode']=false;

I suggest this because a default installation spits out error messages when the entire setting is commented out. I logged in for the first time and immediately changed the root admin password, only to see this error:

Notice: Undefined index: demomode in /home/brian/public_html/livechat/class/operator.php on line 257

It appears operator.php is looking for that setting and errors when it's commented out.

Just a small suggestion. Thanks for all your work.

BT
Logged
HCL Admin
Administrator
HCL Superstar
*****
Offline Offline

Posts: 882


WWW
« Reply #1 on: September 14, 2007, 12:39:57 AM »

Whoops, it was supposed to just be turned off in the production version.  My bad!  Roll Eyes
Logged

how may I help you today?
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.8 | SMF © 2006-2008, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 0.165 seconds with 20 queries.

Google visited last this page July 19, 2014, 09:37:19 AM