Help Center Live Community
April 17, 2014, 07:57:39 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1]   Go Down
  Print  
Author Topic: Custom Links  (Read 3979 times)
johnny_n
Not too much to say...
*
Offline Offline

Posts: 4


« on: February 20, 2008, 05:53:42 PM »

Hi --

Just installed HCL and find it very impressive.

One thing I'm having trouble with -- I want to use my own links to initiate chat and I want two separate buttons on the page -- one for department one, another for department two.

I can't seem to get both the java functionality (chat-sized window, department selected) without the HCL image, even when I replace the image links.  What happens is my buttons work but the HCL images are behind them -- and no matter if an operator is online, the chat window says operators are busy.

This is what I have:

Code:
<div id="econtact2"><a href="javascript:Live.initiate_accept();" class="nb" onmouseover="MM_swapImage('Image4','','images/chat1_over.png',1)" onmouseout="MM_swapImgRestore()"><img src="images/chat1.png" name="Image4" width="62" height="21" border="0" id="Image4" /></a><script type="text/javascript" language="javascript" src="http://www.xxx.com/xxx/hcl/class/js/include.php?live&departmentid=1"></script></div>

<div id="econtact3"><a href="javascript:Live.initiate_accept();" class="nb" onmouseover="MM_swapImage('Image5','','images/chat2_over.png',1)" onmouseout="MM_swapImgRestore()"><img src="images/chat2.png" name="Image5" width="62" height="21" border="0" id="Image5" /></a><script type="text/javascript" language="javascript" src="http://www.xxx.com/xxx/hcl/class/js/include.php?live&departmentid=2"></script></div>

When I use the HTML links instead of the java links, I get a whole new window instead of the chat-sized window (
Code:
target=_blank"
) and even when I replace the "
Code:
?departmentid=
", I still get a prompt asking where the chat should be directed.

Surely others have encountered this -- what's the best fix?

Any ideas would be appreciated!

Best--
john

-- EDIT: I've got a fix, it's not pretty so if anyone has a better idea I'm all ears.  I replaced the two standard images /icons/offline.gif & online.gif with 1x1 transparent gifs.  I then replaced the java code with this:

Code:
javascript:Live.launch('chat', '1', '') and javascript:Live.launch('chat', '2', '')

Seems to work just fine.  Have I broken anything?
« Last Edit: February 20, 2008, 06:12:35 PM by johnny_n » Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.8 | SMF © 2006-2008, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 0.163 seconds with 19 queries.

Google visited last this page Yesterday at 09:18:08 PM