Help Center Live Community
April 25, 2014, 07:30:49 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1]   Go Down
  Print  
Author Topic: Warning: Cannot modify header information  (Read 5699 times)
johnnyboy
Not too much to say...
*
Offline Offline

Posts: 2


« on: July 22, 2007, 09:21:40 AM »

Hello,
I've installed the latest version of helpcenter. The sql and php versions are OK. The installation workt well.

Now i get this error every time. This is a basic installation.
savemode is true, language is english.
With everything i do i get this 'header already sent' error. This is in the admin and in the client site.

Warning: Cannot modify header information - headers already sent by (output started at /home/sitefor/domains/sites4hire.nl/public_html/lhc/config.php:1)

the url is www.sites4hire.nl/hlc

thnxx

Logged
HCL Admin
Administrator
HCL Superstar
*****
Offline Offline

Posts: 882


WWW
« Reply #1 on: July 22, 2007, 05:35:52 PM »

Check your version.php and config.php for extra bits at the beginning of the file (before the first <?php)  Not sure what is going on with it, but for some reason some people are getting these.  You can use ultraedit to edit these files, as it can see the garbage (not many editors will even show them)...
Logged

how may I help you today?
phpfixer
Guest
« Reply #2 on: July 23, 2007, 05:13:06 PM »

also check for any blank lines and empty spaces before or after the <?php and ?> - these are also considered HTML output, and any php functions that set http headers will have this error if there is any htmlm output sent before they are executed.

Most common: a blank space at top of config file, or after the ?> closing tag , and/or user uploaded file in Binary (on a linux system, Windows newlines will show as ^M because Linux doesnt recognize the windows CR/LF) - UNIX newlines (LF or \n) arent a problem.

the error seems to indicate that the config file was edited (possibly in MS Word?) and a space or blank line was inserted before the <?php opening tag.
 OR the file was uploaded in binary mode after editing and saving.

Files should only be edited in windows notepad, or better yet a dedicated programming editor (perhaps crimsoneditor - its free) and, if uploading to a 'nix flavored machine, save files with UNIX line endings and/or upload only in ASCII mode.
Logged
johnnyboy
Not too much to say...
*
Offline Offline

Posts: 2


« Reply #3 on: July 23, 2007, 10:08:40 PM »

Thanx, i've found the problem. Al versions were fine but you were right about the edittor error. I use Notepad in windows and saved it wrong. Now i saved it as an ANSI-file and see here.. it works OK!

Thanx for the help!
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.8 | SMF © 2006-2008, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 0.164 seconds with 18 queries.

Google visited last this page April 16, 2014, 03:41:40 AM