Help Center Live Community
April 16, 2014, 11:45:56 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1] 2 3 4   Go Down
  Print  
Author Topic: Windows Installation  (Read 40126 times)
belite
Guest
« on: June 26, 2007, 02:47:19 PM »

Hey,

I'd like you to take a look at <URL Removed for safety>
The setup is not working and I don't know why Sad

Regards,
Ben
« Last Edit: June 26, 2007, 03:00:28 PM by mlzhosting » Logged
HCL Admin
Administrator
HCL Superstar
*****
Offline Offline

Posts: 882


WWW
« Reply #1 on: June 26, 2007, 02:58:03 PM »

Again, you must give the web server write permissions to certain directories.  Make sure the web server user EXPLICITLY can write to icons/ compile/ cache/ and config.php

That is why your getting those errors.
Logged

how may I help you today?
belite
Guest
« Reply #2 on: June 26, 2007, 03:12:22 PM »

Hey,

but the first line says:
Warning: Smarty error: problem creating directory 'C:/Inetpub' in C:\Inetpub\vhosts\belite.de\httpdocs\support\class\smarty\Smarty.class.php on line 1115

Why does it want to create C:/Inetpub ? That folder already existst.

I'll check the permissions now!
Logged
belite
Guest
« Reply #3 on: June 26, 2007, 03:14:47 PM »

The system is Plesk, so the user "Plesk IIS User" got FULL CONTROL to icons/ compile/ cache/ and config.php

Error is still the same!
Logged
HCL Admin
Administrator
HCL Superstar
*****
Offline Offline

Posts: 882


WWW
« Reply #4 on: June 26, 2007, 03:23:44 PM »

It shows that because it's not able to dig down the directories, because the permissions are wrong.  The only way to get those errors is if the script can not create the files and directories errors.  The script requires Read/write/execute access to those directories at the very least. Those errors show that it can NOT write to the files/directories.

If plesk is not setting it correctly, you'll need to speak to your hosting provider.  If anyone else has plesk experience (we don't use it here), they may chime in with some advice as well.
Logged

how may I help you today?
belite
Guest
« Reply #5 on: June 26, 2007, 03:25:17 PM »

But does the script want to create the directory C:/inetpub? It has no rights to do this!
Logged
HCL Admin
Administrator
HCL Superstar
*****
Offline Offline

Posts: 882


WWW
« Reply #6 on: June 26, 2007, 03:35:03 PM »

Depending on how your server is setup, it could be picking it up from PHP.  It will try several ways create the file.

If this is version 2.1.2, there is no predefined place for c:/inetpub (which isn't actually a valid path under windows).  It picks everything up from the servers config.

create a file called phpinfo.php with the following contents:

Code:
<?
phpinfo();
?>
and upload to your base HCL directory.  Then we can see what PHP is reporting.
Logged

how may I help you today?
belite
Guest
« Reply #7 on: June 26, 2007, 03:38:44 PM »

I have root rights, so I've set them directly, not using plesk.

I've created the phpinfo file - http://belite.de/phpinfo.php

I am using v2.1.2 of course.
Logged
belite
Guest
« Reply #8 on: June 26, 2007, 03:40:56 PM »

I changed from PHP version 4.4.3 to 5.2.0
Logged
belite
Guest
« Reply #9 on: June 26, 2007, 03:43:46 PM »

Now the Setup is working, but after I click 'submit' on the last page (I think it is the last page) I get this error:

Quote
Field 'picture' doesn't have a default value

INSERT INTO `hcl_operators` (`username`, `password`, `firstname`, `lastname`, `email`, `showpic`, `autosave`, `level`) VALUES ("admin", "21232f297a57a5a743894a0e4a801fc3", "Default", "User", "admin@example.com", "0", "1", "0")
Logged
HCL Admin
Administrator
HCL Superstar
*****
Offline Offline

Posts: 882


WWW
« Reply #10 on: June 26, 2007, 03:44:06 PM »

And tada, it works.  Must have been something in the php 4.4.3 config.
Logged

how may I help you today?
HCL Admin
Administrator
HCL Superstar
*****
Offline Offline

Posts: 882


WWW
« Reply #11 on: June 26, 2007, 03:45:14 PM »

That's a known issue.  See this post http://www.helpcenterlive.com/smf/index.php/topic,23.0.html
Logged

how may I help you today?
belite
Guest
« Reply #12 on: June 26, 2007, 03:53:24 PM »


Hey, I downloaded the Zip-File and replaced the index.php located in the setup folder.

http://www.belite.de/support/setup/

By the way, my MySQL Version is 5.0.27
Logged
HCL Admin
Administrator
HCL Superstar
*****
Offline Offline

Posts: 882


WWW
« Reply #13 on: June 26, 2007, 03:57:36 PM »

You uploaded setup.php to /setup/index.php?  If so, you need to go from the install package and reupload index.php.

The zip file contains a replacement for /class/setup.php  It's a series of functions, not a replacement for the index.php
Logged

how may I help you today?
belite
Guest
« Reply #14 on: June 26, 2007, 04:02:20 PM »

You uploaded setup.php to /setup/index.php?  If so, you need to go from the install package and reupload index.php.

The zip file contains a replacement for /class/setup.php  It's a series of functions, not a replacement for the index.php


I did and ran the setup:


Warning: fopen(C:\Inetpub\vhosts\belite.de\httpdocs\support\setup/../config.php) [function.fopen]: failed to open stream: Permission denied in C:\Inetpub\vhosts\belite.de\httpdocs\support\class\file.php on line 105

Warning: fwrite(): supplied argument is not a valid stream resource in C:\Inetpub\vhosts\belite.de\httpdocs\support\class\file.php on line 107

Warning: fclose(): supplied argument is not a valid stream resource in C:\Inetpub\vhosts\belite.de\httpdocs\support\class\file.php on line 109

What Windows permissions do I have to set?
Logged
Pages: [1] 2 3 4   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.8 | SMF © 2006-2008, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 0.162 seconds with 18 queries.

Google visited last this page Yesterday at 09:23:35 PM